pat1002

1002. A+B for Polynomials (25)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2


#include<cstdio>
#include<vector>
#include<iostream>
#include<cstring>
#include<algorithm>
const int maxn = 1005;
using namespace std;
vector<double> pile[maxn];
int flag[maxn];
int main(){
	int k, a, n=0;
	double b,sum;
	int N[12],c=0;
	memset(flag,0,sizeof(flag));
	for(int j =0; j < 2; j++){
		scanf("%d",&k);
		for(int i =0; i < k; i++){
			scanf("%d %lf", &a, &b);
			pile[a].push_back(b);
			if(flag[a]==0){
				flag[a]=1;
				N[c++]=a;
			}
		}
	}
	sort(N,N+c);
	printf("%d ", c);
	for(int i =c-1; i > 0; i--){
		sum = 0.0;
		for(int j = 0 ; j < pile[N[i]].size(); j++){
			sum += pile[N[i]][j];
		}
		
		printf("%d %0.1lf ", N[i], sum);
	}
	sum=0.0;
	for(int j = 0 ; j < pile[N[0]].size(); j++){
		sum += pile[N[0]][j];
		printf("%d %0.1lf", N[0], sum);
	}
	return 0;
}

運行結果 有幾個測試點未通過 忽略了多項式相加係數爲0的情況

然後將代碼改了一下,上面的空格輸出麻煩了,改了一下,結果如下 之後又看了一下別人的 發現用結構體很好 寫的時候就想到了vector容器 導致有點麻煩了

#include<cstdio>
#include<vector>
#include<iostream>
#include<cstring>
#include<algorithm>
const int maxn = 1005;
using namespace std;
vector<double> pile[maxn];
int flag[maxn];
int main(){
	int k, a, n=0;
	double b,sum;
	int N[12],c=0;
	memset(flag,0,sizeof(flag));
	for(int j =0; j < 2; j++){
		scanf("%d",&k);
		for(int i =0; i < k; i++){
			scanf("%d %lf", &a, &b);
			pile[a].push_back(b);
			if(flag[a]==0){
				flag[a]=1;
				N[c++]=a;
			}
		}
	}
	sort(N,N+c);
	int m=c;
	//printf("%d", c);
	for(int i =c-1; i >= 0; i--){
		sum = 0.0;
		for(int j = 0 ; j < pile[N[i]].size(); j++){
			sum += pile[N[i]][j];
		}
		if(sum==0){
			m--;
		}
	}
	printf("%d", m);
	for(int i =c-1; i >= 0; i--){
		sum = 0.0;
		for(int j = 0 ; j < pile[N[i]].size(); j++){
			sum += pile[N[i]][j];
		}
		if(sum!=0)
		printf(" %d %0.1lf", N[i], sum);
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章