pat甲級1006

1006. Sign In and Sign Out (25)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct stu{
	char id[16];
	int h,m,s;
}s1[100],s2[100];
int cmp1(stu a, stu b){
	if(a.h!=b.h)
		return a.h<b.h;
	else if(a.m != b.m)
		return a.m<b.m;
	else if(a.s != b.s)
		return a.s<b.s;
}
int cmp2(stu a, stu b){
	if(a.h!=b.h)
		return a.h>b.h;
	else if(a.m != b.m)
		return a.m>b.m;
	else if(a.s != b.s)
		return a.s>b.s;
}
int main(){
	int M;
	scanf("%d", &M);

	for(int i = 0; i < M; i++){
		scanf("%s %d:%d:%d ", s1[i].id, &s1[i].h,&s1[i].m,&s1[i].s);
		
		scanf("%d:%d:%d",&s2[i].h,&s2[i].m,&s2[i].s);
		strcpy(s2[i].id,s1[i].id);
	}
	sort(s1, s1+M, cmp1);
	printf("%s ", s1[0].id);
	sort(s2, s2+M, cmp2);
	printf("%s", s2[0].id);
	return 0;
}

後來看其他一個博主寫的很好 直接strcmp

連接:https://blog.csdn.net/leonardo1897/article/details/48681689

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章