HDU 1711 子序列

Number Sequence

 

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 


 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 


 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 


 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 


 

Sample Output
6 -1

KMP算法

求第二個在第一個出現的位置

 

#include <iostream>
using namespace std;
int p[11111],n,m;
int a[1111111],b[11111];
void getnext()//子串的p數組
{
	int i=0,j=-1;
	p[0]=-1;
	while(i<m)
	{
		if(j==-1||b[i]==b[j])
		{
			i++; j++;
			p[i]=j;
		}
		else
			j=p[j];
	}
}
int kmp()
{
	int i=0,j=0;//比較時j=0
	getnext();
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		{
			i++;j++;
		}
		else
			j=p[j];
		if(j==m)
			return i-j+1;
	}
	return -1;
}
int main()
{
	int i,t;
	scanf("%d",&t);
	while(t--)
	{
		memset(p,0,sizeof(p));
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);
		printf("%d\n",kmp());
	}
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章