Max Sum Plus Plus HDU - 1024(dp)

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 
InputEach test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 
OutputOutput the maximal summation described above in one line. 
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8


        
  
Hint

Huge input, scanf and dynamic programming is recommended.


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define max(a,b) (a>b?a:b)
#define MAX 1000001
#define INF 0x7fffffff
 int dp[3][MAX];
 int w[MAX];
 int sum[MAX];
int main()
{
    int n,m,i,j,k;
    while(~scanf("%d%d",&m,&n))
    {
        sum[0]=0;
        for(i=1;i<=n;i++)
        {
            cin>>k;
            sum[i]=sum[i-1]+k;
            dp[0][i]=0;
        }
        for(i=1;i<=m;i++)
        {
            for(j=i;j<=n;j++)
            {
                if(j==i)
                {
                    dp[i%2][j]=sum[i];
                    w[j]=sum[i];
                }
                else
                {
                    w[j]=max(dp[(i+1)%2][j-1],w[j-1])+sum[j]-sum[j-1];
                    dp[i%2][j]=max(dp[i%2][j-1],w[j]);
                
                }
            }
        }
        cout<<dp[m%2][n]<<endl;
    }
   return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章