A - Max Sum HDU - 1003 (dp)

A - Max Sum

  HDU - 1003
Time limit 1000 ms Memory limit 32768 kB OS Windows







InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
    int T,n,a[100001],i,k,sum,b,c,d,max;
    scanf("%d",&T);
    for(k=1;k<=T;k++)
    {
        scanf("%d",&n);
        scanf("%d",&a[0]);
        b=0;c=0;sum=a[0];max=a[0];d=0;
        for(i=1;i<n;i++)
        {
            scanf("%d",&a[i]);

            if(sum<0)
            {
                sum=0;
                b=i;
            }
            sum=sum+a[i];
             if(sum>max)
            {
                d=b;
                max=sum;
                c=i;
            }
        }
        printf("Case %d:\n",k);
        printf("%d %d %d\n",max,d+1,c+1);
        if(k!=T)
        {
            printf("\n");
        }
    }
return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章