HDU 4848 Wow! Such Conquering! (記憶化搜索,剪枝)

Wow! Such Conquering!

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2618    Accepted Submission(s): 790

Problem Description

There are n Doge Planets in the Doge Space. The conqueror of Doge Space is Super Doge, who is going to inspect his Doge Army on all Doge Planets. The inspection starts from Doge Planet 1 where DOS (Doge Olympic Statue) was built. It takes Super Doge exactly Txy time to travel from Doge Planet x to Doge Planet y.
With the ambition of conquering other spaces, he would like to visit all Doge Planets as soon as possible. More specifically, he would like to visit the Doge Planet x at the time no later than Deadlinex. He also wants the sum of all arrival time of each Doge Planet to be as small as possible. You can assume it takes so little time to inspect his Doge Army that we can ignore it.

Input

There are multiple test cases. Please process till EOF.
Each test case contains several lines. The first line of each test case contains one integer: n, as mentioned above, the number of Doge Planets. Then follow n lines, each contains n integers, where the y-th integer in the x-th line is Txy . Then follows a single line containing n - 1 integers: Deadline2 to Deadlinen.
All numbers are guaranteed to be non-negative integers smaller than or equal to one million. n is guaranteed to be no less than 3 and no more than 30.

Output

If some Deadlines can not be fulfilled, please output “-1” (which means the Super Doge will say “WOW! So Slow! Such delay! Much Anger! . . . ” , but you do not need to output it), else output the minimum sum of all arrival time to each Doge Planet.

Sample Input

4

0 3 8 6

4 0 7 4

7 5 0 2

6 9 3 0

30 8 30

4

0 2 3 3

2 0 3 3

2 3 0 3

2 3 3 0

2 3 3

Sample Output

36 -1

Hint

Explanation: In case #1: The Super Doge travels to Doge Planet 2 at the time of 8 and to Doge Planet 3 at the time of 12, then to Doge Planet 4 at the time of 16. The minimum sum of all arrival time is 36.

 Source

2014西安全國邀請賽

Recommend

liuyiding

求1到每個點的最短時間而且不能超過截止時間。輸出每個Doge Planet的所有到達時間的最小總和。

如果超截止時間就輸出 -1

先用floyd鬆弛一下點與點之間的最短距離,然後再dfs暴搜最小的和

剪枝,一、每一步的時間和sumtim必須小於結果ans,

二、到達每一步的時間都必須要保證到達後面點的所有時間都來得及

#include<iostream>
#include<cstdio>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int n,ans;
int map[35][35],dl[35],maxdl;
int vis[35]; 
void floyd()
{
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(map[i][j]>map[i][k]+map[k][j])
				{
					map[i][j]=map[i][k]+map[k][j];
				}
			}
		}
	}
}
void dfs(int pos,int hasnum,int tim,int kk,int sumtim)
{
	if(tim>maxdl) return;
	if(tim>dl[pos]) return;
	if(sumtim>ans) return;//很重要 
	for(int i=2;i<=n;i++)
	{
		if(!vis[i]&&tim+map[pos][i]>dl[i]) return;
	}
	if(hasnum==n)
	{
		if(sumtim<ans) ans=sumtim;
		return;
	}
	for(int i=2;i<=n;i++)
	{
		if(vis[i]) continue;
		vis[i]=1;
		dfs(i,hasnum+1,tim+map[pos][i],kk-1,sumtim+map[pos][i]*kk);//sumtim預處理了很多組數據 
		vis[i]=0;
	}
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&map[i][j]);
			}
		}
		maxdl=-1;
		for(int i=2;i<=n;i++)
		{
			scanf("%d",&dl[i]);
			if(maxdl<dl[i]) maxdl=dl[i];
		}
		floyd();
		ans=inf;
		memset(vis,0,sizeof(vis));
		dfs(1,1,0,n-1,0);
		if(ans==inf) printf("-1\n");
		else printf("%d\n",ans);
	}
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章