最短路 hdu2923

Einbahnstra  e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.) 

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

 

Input

Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats: 


A -v -> B 
A <-v - B 
A <-v -> B 


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .) 

The test case in the example below is the same as the one in the figure. 
 

 

Output

For each test case, print the total distance traveled using the following format: 


k . V 


Where k is test case number (starting at 1,) is a space, and V is the result.

 

Sample Input


 

4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0

 

Sample Output


 

1. 80

本來這道題沒什麼好寫博客的,但是爲了讓自己下次注意

有重邊!有重邊!有重邊!

我開始以爲只是一個dijkstra,結果寫着寫着發現他好像還要回來。然後又準備對每個點求一次最短路,這不就是個Floyd。。。

本蒟蒻佛了,好吧,那就Floyd吧

#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <ctype.h>
#include <bitset>
#define  LL long long
#define  ULL unsigned long long
#define mod 10007
#define INF 0x7ffffff
#define mem(a,b) memset(a,b,sizeof(a))
#define MODD(a,b) (((a%b)+b)%b)
//#define maxn 50
using namespace std;
const int maxn = 3e2 + 5;
int n,k,m,cnt;
vector<string> V;
int ma[maxn][maxn];
map<string,int> mp;
struct Edge
{
    int next,to,w;
}e[maxn];
void init(){
  mp.clear();
  V.clear();
  cnt = 1;
  for(int i = 0; i <= n; i++){
    for(int j = 0; j <= n; j++){
        if(i == j) ma[i][j] = 0;
        else ma[i][j] = INF;
    }
  }
}
int fun(char s[])
{
    int len = strlen(s);
    int flag = 0;
    int sum = 0;
    for(int i = len - 1; i >= 0; i--){
      if(isdigit(s[i])) {sum += pow(10,flag)*(s[i] - '0');flag++;}
    }
    return sum;
}
void floyd()
{
    for(int k = 1; k <= n; k++){
      for(int i = 1; i <= n; i++){
        for(int j  = 1; j <= n; j++){
            if(ma[i][k] + ma[k][j] < ma[i][j]) ma[i][j] = ma[i][k] + ma[k][j];
        }
      }
    }
}
int main()
{
    int flag = 0;
    while(~scanf("%d%d%d",&n,&k,&m) && (n + m + k)){
      init();

      for(int i = 0; i <= k; i++){
        char str[12];
        scanf("%s",str);
        V.push_back(str);
        if(!mp[str])
            mp[str] = cnt++;
            //printf("%d\n",mp[str]);
      }
      while(m--){
        char from[12],mid[12],to[12];
        scanf("%s%s%s",from,mid,to);
        if(!mp[from]) mp[from] = cnt++;
        if(!mp[to]) mp[to] = cnt++;
        int a = mp[from],b = mp[to];
        int val = fun(mid);
        int len = strlen(mid);
        if(mid[0] == '<' && mid[len - 1] == '>'){
          if(ma[a][b] > val) ma[a][b] = val;
          if(ma[b][a] > val) ma[b][a] = val;
        }
        else if(mid[0] == '<'){
            if(ma[b][a] > val) ma[b][a] = val;
        }
        else if(mid[len - 1] == '>'){
            if(ma[a][b] > val) ma[a][b] = val;
        }


      }
      floyd();
      int ans = 0;
      for(vector<string>::iterator it = V.begin(); it != V.end(); it++){
          ans += ma[1][mp[*it]] + ma[mp[*it]][1];
        }
        printf("%d. %d\n",++flag,ans);
    }





    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章