挑戰2.3 Cow Bowling(POJ 3176)

Cow Bowling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14681   Accepted: 9763

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

題目大意:

給你一個數字三角形,然後輸出從a[1][1]到最後一行的某條線路上的最大的和,每次的行走路線只能走向下或者向右的路線。

解題思路:

裸裸的DP模板,數字三角形問題,我用的是從下往上的遞推,也就是說,從倒數第n-1行開始,選擇一個數字,使得這個數在加上第n行的數字後

他的和在目前這些數字中達到最大。然後每層都採用這樣的思路進行循環,最後輸出a[1][1]就表示了從第一行的第一個數字到最後一行的某個數字的和

的最大值.

狀態:a[i][j]表示的是從第i行第j列的數字到最後一行的某個數字的和的最大值。

狀態轉移方程:a[i][j]+=max(a[i+1][j],a[i+1][j+1])


代碼:

# include<cstdio>
# include<iostream>
# include<algorithm>
# include<cstring>
# include<string>
# include<cmath>
# include<queue>
# include<stack>
# include<set>
# include<map>

using namespace std;

typedef long long LL;

# define inf 999999999
# define MAX 350+4

int a[MAX][MAX];
LL ans;
int n;

int main(void)
{
    while ( cin>>n )
    {
        getchar();
        for ( int i = 1;i <= n;i++ )
        {
            for ( int j = 1;j <= i;j++ )
            {
                cin>>a[i][j];
            }
        }

        for ( int i = n-1;i >= 1;i-- )
        {
            for ( int j = 1;j <= i;j++ )
            {
                a[i][j]+=max( a[i+1][j],a[i+1][j+1]);
            }
        }

        cout<<a[1][1]<<endl;
    }

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章