BIT2014級軟件學院程序設計-18 A Knight's Journey

 

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.

Sample Input

3

1 1

2 3

4 3

Sample Output

Scenario #1:

A1

 

Scenario #2:

impossible

 

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4


最簡單的暴力搜索。

我直接用的DFS,注意方向的先後順序,因爲要最終路徑字典序最小。

#include<stdio.h>
#include<string.h>
int T, m, n;
int vis[30][30];
int dx[8] = { -2,-2,-1,-1,1,1,2,2 };
int dy[8] = { -1,1,-2,2,-2,2,-1,1 };
int sum;
typedef struct {
	int x, y, step;
}NODE;
int check(int x, int y)
{
	if (x > n || x <= 0 || y > m || y <= 0)/////////////////
		return 0;
	if (vis[x][y])
		return 0;
	return 1;
}

int flag;
NODE s[500];
int DFS(int st, int ed, int step)
{
	int i;
	if (step == sum)
	{
		for (i = 1;i <= sum;i++)
			printf("%c%d", s[i].x + 'A' - 1, s[i].y);
		printf("\n");
		return 1;
	}
	NODE now;
	for (i = 0;i < 8;i++)
	{
		now.x = st + dx[i];
		now.y = ed + dy[i];
		now.step = step + 1;
		if (check(now.x, now.y))
		{
			s[now.step].x = now.x;
			s[now.step].y = now.y;
			vis[now.x][now.y] = 1;
			flag = DFS(now.x, now.y, now.step);
			if (flag)
				return 1;
			vis[now.x][now.y] = 0;
		}


	}
	return 0;
}
int main()
{
	//freopen("E:in.txt","r",stdin);
	//freopen("E:out1.txt","w",stdout);
	int tmp;
	scanf("%d", &T);
	for (tmp = 1;tmp <= T;tmp++)
	{
		printf("Scenario #%d:\n", tmp);
		memset(s, 0, sizeof(s));
		memset(vis, 0, sizeof(vis));
		flag = 0;

		scanf("%d%d", &m, &n);//m是幾個數字n是字母
		sum = m*n;
		vis[1][1] = 1;s[1].x = 1;s[1].y = 1;
		if (!DFS(1, 1, 1))
			printf("impossible\n");
		if(tmp!=T)
		printf("\n");


	}
}



/*
123456789m
A
B
C
D
E
F
G
n
*/



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章