最大长方形

最大长方形(二)

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
样例输入
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
样例输出
8
4000
个人理解:考虑用单调队列的思路,先将所有高度的数据存入栈中,逐次进行比较,如果后面的数据小于前面的,将前面的数据压出栈中,并将对应的长度与单调匹配的高度与之相乘得到相应的面积,然后按照上面的思路将压出栈的面积比较,取最大面积进行输出处理。

#include<cstdio>
#include<iostream>
using namespace std;
int stack[100010]={-2},len[100010];
long long ans;
int main() {
	int n,top,h;
	while(scanf("%d",&n), n) {
		top=0;ans=0;
		for(int i=0;i<=n;i++) {
			if(i<n)scanf("%d",&h);
			else h=-1;
			if(h > stack[top]) {
				stack[++top]=h;
				len[top]=1;
			} else {
				int l = 0;
				while(stack[top] >= h) {
					ans=max(ans,(long long)(l+len[top])*stack[top]);
					l += len[top--];
				}
				stack[++top] = h;
				len[top] = l + 1;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章