POJ-Primes

Problem Description
Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes. 
 

Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
 

Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no". 
 

Sample Input
1 2 3 4 5 17 0
 

Sample Output
1: no 2: no 3: yes 4: no 5: yes 6: yes

個人理解:判斷輸入的數是否爲質數,如果是質數則輸出yes,不是質數則輸出no,同時如果輸入1,2則輸出no,時間15Ms,內存1504K,代碼長度458B,語言G++



#include<stdio.h>
#include<math.h>
main()
{
    int i=3,k,m,count=0;
    scanf("%d",&i);
            while(i>0){
            k=sqrt(i);//判別i是否爲素數,只需使2-根號i之間的每個數去除
            for(m=2;m<=k;m++)
               if(i%m==0)
                 break;
            if(m<=k||i<3)
                printf("%d: no\n",++count);
            else
                printf("%d: yes\n",++count);
            scanf("%d",&i);
            }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章