Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
題解:經典的最短路徑。。。代碼如下:

#include<cstdio>
#include<vector>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue> 
using namespace std;
int len[1010];
const int inf=0x3f3f3f3f;
struct node{
	int t;
	int len;
};
vector<node> v[1010];
int t,n;
int dis[1010];
void spfa(int s,int t){
	queue<int> que;
	que.push(s);
	memset(dis,inf,sizeof(dis));
	dis[s]=0;
	while(!que.empty()){
		int cur=que.front();
		que.pop();
		for(int i=0;i<v[cur].size();i++){
			node n1=v[cur][i];
			if(dis[cur]+n1.len<dis[n1.t]){
				dis[n1.t]=dis[cur]+n1.len;
				que.push(n1.t);
			}
		}
	}
}
int main()
{
	
	scanf("%d %d",&t,&n);
	for(int i=0;i<t;i++){
		int a,b,len;
		scanf("%d%d%d",&a,&b,&len);
		v[a].push_back({b,len});
		v[b].push_back({a,len});
	}
	spfa(1,n);
	printf("%d",dis[n]);
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章