POJ 3186 - Treats for the Cows(DP)

Treats for the Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5729 Accepted: 2963
Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output

Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input

5
1
3
1
5
2
Sample Output

43
Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

題意:
給出一個數列, 每次從兩頭中拿出一個, 把拿出來的這個數乘以拿的次數加到結果中.
求結果的最大值.

解題思路:
這個題不能用貪心的思想做, 因爲裏面的數並不知道, 所以要用到DP.
從兩頭往中間收縮,

dp[i][j] = max(dp[i][j], dp[i-1][j] + a[i]*(i+j));
dp[i][j] = max(dp[i][j], dp[i][j-1] + a[n-j+1]*(i+j));

AC代碼:

#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 2e3+5;
int dp[maxn][maxn];
int a[maxn];
int main()
{
    ios::sync_with_stdio(0);
    int n;
    cin >> n;
    for(int i = 1; i <= n; i++)
        cin >> a[i];
    for(int i = 0; i <= n; i++){
        for(int j = 0; j <= n; j++){
            if(i - 1 >= 0)
                dp[i][j] = max(dp[i][j], dp[i-1][j] + a[i]*(i+j));
            if(j-1 >= 0)
                dp[i][j] = max(dp[i][j], dp[i][j-1] + a[n-j+1]*(i+j));
        }
    }
    int res = -1;
    for(int i = 1; i <= n; i++)
        res = max(res, dp[i][n-i]);
    cout << res;
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章