HDU - 1358 - Period(KMP的next數組)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

[分析]
字符串題目凡是涉及到前綴都要考慮一下KMP算法的Next數組。
舉個例子
aabaabaabaab
010123456789
以上是next,next表示的是與前綴的相似程度
找到最後一個0的位置,就是週期的末尾。記爲len;
如果某個next[i]%len==0,那麼表示這個位置可以輸出一次答案,因爲這裏多了一個週期。

[代碼]

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 1234567;
int T, n, m;
int Next[maxn];
char s[maxn];

void GetNext(char t[], int lent)
{
    int i, j;
    i = 0;
    j = Next[0] = -1;
    while (i<lent)
    {
        while (j != -1 && t[i] != t[j])
            j = Next[j];
        Next[++i] = ++j;
    }
}

int main()
{
    int kase = 0;
    while (scanf("%d", &n) != EOF&&n)
    {
        scanf("%s", s);
        GetNext(s, n);
        printf("Test case #%d\n", ++kase);
        for (int i = 0; i <= n; i++)
        {
            int len = i - Next[i];
            if (i%len == 0 && i / len>1)
            {
                printf("%d %d\n", i, i / len);
            }
        }
        printf("\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章