隊列和棧的基本模板

Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output
For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output
1
2
2
1
1
2
None
2
3

解答:基本的兩種操作:

#include<iostream>
#include<stack>
#include<queue>
#include<cstring>
using namespace std;

int main()
{
    int n,m,x,ans;
    char s1[5], s2[5];
    cin >> n;
    while (n--)   //總數
    {
        stack<int>s;
        queue<int>q;
        cin >> m;   //操作數
        scanf("%s", s1);    //FIFO和FIFO
        if (strcmp(s1, "FIFO") == 0)
        {
            for (int i = 1; i <= m; i++)
            {
                scanf("%s", s2);   //具體指令

                if (strcmp(s2, "IN") == 0)   //處理
                {
                    cin >> x;
                    q.push(x);
                }
                else
                {
                    if (q.empty() == 1)   //隊列空
                        cout << "None" << endl;
                    else
                    {
                        ans = q.front();
                        cout << ans << endl;
                        q.pop();
                    }
                }
            }
            if (q.empty() == 0)
                q.pop();
        }
        else
        {
            for (int i = 1; i <= m; i++)
            {
                scanf("%s", s2);
                if (strcmp(s2, "IN") == 0)   
                {
                    cin >> x;
                    s.push(x);
                }
                else
                {
                    if (s.empty() == 1)   
                        cout << "None" << endl;
                    else
                    {
                        ans = s.top();
                        cout << ans << endl;
                        s.pop();
                    }
                }
            }
            if (s.empty() == 0)
                s.pop();
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章