POJ - 2155 Matrix(二維線段樹、區間更新單點查詢)

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 29732   Accepted: 10863

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng


題意:給出一個n*n的01矩陣,操作1是將其中一個子矩陣全部取反,操作2是查詢矩陣內某一元素的值

這題我們並不方便直接將每次操作更新到葉子節點,也不需要打lazy標記,只需要在查詢的時候將從根節點到我們目標節點一路上被更新的次數相加%2


#include <stdio.h>
using namespace std;

const int N = 1e3 + 10;
int t, n, m;
int T[N<<2][N<<2];

void Build2(int l, int r, int deep, int k){
    T[deep][k] = 0;
    if(l == r) return;
    int mid = (l+r)>>1;
    Build2(l, mid, deep, k<<1);
    Build2(mid+1, r, deep, k<<1|1);
}

void Build(int l, int r, int k){
    Build2(1, n, k, 1);
    if(l == r) return;
    int mid = (l+r)>>1;
    Build(l, mid, k<<1);
    Build(mid+1, r, k<<1|1);
}

void Update2(int l, int r, int L, int R, int deep, int k){
    if(l <= L && r >= R){
        T[deep][k]++;
        return;
    }
    int mid = (L+R)>>1;
    if(r <= mid) Update2(l, r, L, mid, deep, k<<1);
    else if(l > mid) Update2(l, r, mid+1, R, deep, k<<1|1);
    else{
        Update2(l, mid, L, mid, deep, k<<1);
        Update2(mid+1, r, mid+1, R, deep, k<<1|1);
    }
}

void Update(int l, int r, int L, int R, int ll, int rr, int k){
    if(l <= L && r >= R){
        Update2(ll, rr, 1, n, k, 1);
        return;
    }
    int mid = (L+R)>>1;
    if(r <= mid) Update(l, r, L, mid, ll, rr, k<<1);
    else if(l > mid) Update(l, r, mid+1, R, ll, rr, k<<1|1);
    else{
        Update(l, mid, L, mid, ll, rr, k<<1);
        Update(mid+1, r, mid+1, R, ll, rr, k<<1|1);
    }
}

int ans;
void Query2(int y, int L, int R, int deep, int k){
    ans += T[deep][k];
    if(L == R) return;
    int mid = (L+R)>>1;
    if(y <= mid) Query2(y, L, mid, deep, k<<1);
    else Query2(y, mid+1, R, deep, k<<1|1);
}

void Query(int x, int y, int L, int R, int k){
    Query2(y, 1, n, k, 1);
    if(L == R) return;
    int mid = (L+R)>>1;
    if(x <= mid) Query(x, y, L, mid, k<<1);
    else Query(x, y, mid+1, R, k<<1|1);
}

int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &n, &m);
        Build(1, n, 1);
        char op[3];
        int x1, y1, x2, y2;
        while(m--){
            scanf("%s", op);
            if(op[0] == 'C'){
                scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                Update(x1, x2, 1, n, y1, y2, 1);
            }
            else{
                scanf("%d%d", &x1, &y1);
                ans = 0;
                Query(x1, y1, 1, n, 1);
                printf("%d\n", ans&1);
            }
        }
        if(t) printf("\n");
    }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章