HDU - 1251 統計難題(字典樹模板題)

統計難題

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 45711    Accepted Submission(s): 16279


Problem Description
Ignatius最近遇到一個難題,老師交給他很多單詞(只有小寫字母組成,不會有重複的單詞出現),現在老師要他統計出以某個字符串爲前綴的單詞數量(單詞本身也是自己的前綴).
 

Input
輸入數據的第一部分是一張單詞表,每行一個單詞,單詞的長度不超過10,它們代表的是老師交給Ignatius統計的單詞,一個空行代表單詞表的結束.第二部分是一連串的提問,每行一個提問,每個提問都是一個字符串.

注意:本題只有一組測試數據,處理到文件結束.
 

Output
對於每個提問,給出以該字符串爲前綴的單詞的數量.
 

Sample Input
banana band bee absolute acm ba b band abc
 

Sample Output
2 3 1 0
 

Author
Ignatius.L
 

Recommend
Ignatius.L
 

Statistic | Submit | Discuss | Note
#include <bits/stdc++.h>
using namespace std;

const int N = 1e6 + 10;
int tot;
char s[1001];
int nex[N][26], cnt[N];

void Init(){
    tot = 0;
    memset(nex[0], -1, sizeof nex[0]);
    cnt[0] = 0;
}

void Insert(char a[]){
    int l = strlen(a);
    int p = 0;
    for(int i = 0; i < l; i++){
        int id = a[i]-'a';
        if(nex[p][id] == -1){
            cnt[++tot] = 0;
            nex[p][id] = tot;
            memset(nex[tot], -1, sizeof nex[tot]);
        }
        p = nex[p][id];
        cnt[p]++;
    }
}

int Query(char a[]){
    int l = strlen(a);
    int p = 0;
    for(int i = 0; i < l; i++){
        int id = a[i]-'a';
        if(nex[p][id] == -1) return 0;
        p = nex[p][id];
    }
    return cnt[p];
}

int main(){
    Init();
    while(gets(s) && strcmp(s, "") != 0){
        Insert(s);
    }
    while(scanf("%s", s) == 1){
        printf("%d\n", Query(s));
    }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章