poj 1256 Anagram

Anagram
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19889   Accepted: 7945

Description

You are to write a program that has to generate all possible words from a given set of letters. 
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". 
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order. 

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3
aAb
abc
acba

Sample Output

Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter. 
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

char s[20];

int cmp(char a,char b){
    if(toupper(a)!=toupper(b))
        return toupper(a)<toupper(b);
    else
        return a<b;
}

int main(){
    int i,t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%s",s);
        n=strlen(s);
        sort(s,s+n,cmp);
        do{
            printf("%s\n",s);
        }while(next_permutation(s,s+n,cmp));
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章