【POJ-1003】Hangover

Hangover
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 87769   Accepted: 42382

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source


由於此題的數據規模很小,可以先離線算出不超過5.20需要的卡片(tot)。
從題目可知 len[i]=len[i-1]+1/(i+1);因此len[tot]隨着卡片tot的增長而增長,滿足單調性,被查數在此區間段上。
考慮使用二分查找、
過程如下:
  初始時[left,right]=[1,tot]  ,中間指針爲mid =(left+right)/2。
  若check(x-len[mid])>0 (即x>len[mid])則區間在右邊,否則在左邊。
  直到left+1>=right 。
#include <stdio.h>

double len[500];
int tot;

int check(double x)
{
	if (x>1e-8) return 1;
	return -1;
}
void pre()
{
	len[0]=0.0;
	for(tot=1;check(5.20-len[tot-1])>0;tot++)
		len[tot]=len[tot-1]+1.0/(tot+1);
}
int main()
{

	double x;
	int left,right,mid;
//	freopen("in.txt","r",stdin);
//	freopen("out.txt","w",stdout);
	pre();
	scanf("%lf",&x);
	while((x-0.0)>1e-8)
	{
		left=0;right=tot;
		while(left+1<right)
		{
			mid=(left+right)/2;
			if (check(x-len[mid])>0) left=mid;
				else right=mid;
		}
		printf("%d card(s)\n",right);
		scanf("%lf",&x);
	}

}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章