HDU 5671 Matrix

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1398    Accepted Submission(s): 557


Problem Description
There is a matrix M that has n rows and m columns (1n1000,1m1000).Then we perform q(1q100,000) operations:

1 x y: Swap row x and row y (1x,yn);

2 x y: Swap column x and column y (1x,ym);

3 x y: Add y to all elements in row x (1xn,1y10,000);

4 x y: Add y to all elements in column x (1xm,1y10,000);
 

Input
There are multiple test cases. The first line of input contains an integer T(1T20) indicating the number of test cases. For each test case:

The first line contains three integers n, m and q.
The following n lines describe the matrix M.(1Mi,j10,000) for all (1in,1jm).
The following q lines contains three integers a(1a4), x and y.
 

Output
For each test case, output the matrix M after all q operations.
 

Sample Input
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
 

Source
 

Recommend
wange2014
 

這個題好費腦子啊TAT英語很簡單,不翻譯了。

就是把最先開始的地圖的順序當做二維數組存起來。然後二維數組的角標是不斷更新的地圖。最後按照角標順序輸出原地圖就好。

就是兩個圖轉換這塊想起來感覺腦袋都要打彎了= =


#include<stdio.h>
#include<string.h>
int map[1010][1010],x[1010],y[1010];
int addx[1010],addy[1010];
int main()
{
	int T;
	int i,j,a,b,t,n,m,q;
	scanf("%d",&T);
	while(T--)
	{
		memset(addx,0,sizeof(addx));
		memset(addy,0,sizeof(addy));
		scanf("%d%d%d",&n,&m,&q);
		for(i=1;i<=n;i++)
		{
			x[i]=i;
			for(j=1;j<=m;j++)
			{
				y[j]=j;
				scanf("%d",&map[i][j]);
			}
		}
		while(q--)
		{
			scanf("%d%d%d",&t,&a,&b);
			if(t==1)
			{
				int tmp=x[a];
				x[a]=x[b];
				x[b]=tmp;
			}
			else if(t==2)
			{
				int tmp=y[a];
				y[a]=y[b];
				y[b]=tmp;
			}
			else if(t==3)
				addx[x[a]]+=b;
			else
				addy[y[a]]+=b;
		}
		for(i=1;i<=n;i++)
		{
			printf("%d",map[x[i]][y[1]]+addx[x[i]]+addy[y[1]]);
			for(j=2;j<=m;j++)
			{
				printf(" %d",map[x[i]][y[j]]+addx[x[i]]+addy[y[j]]);
			}
			printf("\n");
		}
	}
	return 0;
 } 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章