九度OJ--1440

题目1440:Goldbach's Conjecture

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1822

解决:1124

题目描述:

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

输入:

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

输出:

Each output line should contain an integer number. No other characters should appear in the output.

样例输入:
6
10
12
0
样例输出:
1
2

1


#include<iostream>
#include<stdio.h>
#include<math.h>
#define Max 60000
using namespace std;
bool Mark[Max];  //作为标记该数是否标记过 
int prime[Max];  //作为存储素数的数组 
int primesize;   //用于记录素数一共有多少个 
void Isprime(){
	for(int i=0;i<Max;i++){
		Mark[i]=false;
	}
	primesize=0;
	for(int i=2;i<Max;i++){
	if(!Mark[i]){
		prime[primesize++]=i;
	for(int j=2*i;j<Max;j+=i)
		Mark[j]=true;	
	}}
}
int Prime1(int x){
	int count=sqrt(x)+1;
	for(int i=2;i<count;i++){
		if(x%i==0){
			return 0;
		}
	}
	return 1;
}
int main(){
	int n;
	int count1;
	Isprime();
	while(scanf("%d",&n)!=EOF){
		count1=0;
		if(n==0)
			break;
		int sum=n/2+1;
		for(int i=0;i<primesize&&prime[i]<sum;i++){
			if(Prime1(n-prime[i]))
				count1++;
		}	
		printf("%d\n",count1);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章