POJ 3006:Dirichlet's Theorem on Arithmetic Progressions題解報告(C++)

原題網址:http://poj.org/problem?id=3006


題目描述:

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., a, a + d, a + 2d, a + 3d, a + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers a, d, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, d, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset a, d, n should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

大致題意:

給定一個素數a和d,則a+d,a+2d.....a+nd中存在無窮多的素數,輸入a,d和m,輸出a+nd數列中的第m個素數。大致看下輸入輸出樣例就可以明白了。


題解思路:

這個題如果一個一個判斷的話絕對會超時2333,所以就要找別的辦法了。看題目中給的很特殊的數據範圍,還有一句話“輸出結果一定不大於10^6”,這意圖就很明顯了,打表哇!先生成素數表,然後拿着a+nd和素數表比較來判斷是否是素數,這樣就絕對不會超時了。


下面是代碼:

#include<iostream>
#include<cstring>
using namespace std;

#define maxn 1000000
const int n = 1000000;
bool isprime[n + 1];
int primenum[maxn], cnt;


void Euler()			//歐拉篩,生成素數表
{
	memset(isprime, true, sizeof(isprime));
	isprime[1] = false;
	for (int i = 2; i <= n; i++)
	{
		if (isprime[i])primenum[++cnt] = i;
		for (int j = 1; j <= cnt && i*primenum[j] <= n; j++)
		{
			isprime[i*primenum[j]] = false;
			if (i%primenum[j] == 0)break;
		}
	}
}

int main()
{
	Euler();

	int a, d, n;
	
	while (cin >> a >> d >> n)
	{

		if (a == 0 && d == 0 && n == 0)
		{
			break;
		}

		int flag = 0;
		int count = 0;
		while (count != n)
		{
			while (primenum[flag] < a)
			{
				flag++;
			}
			if (a == primenum[flag])
			{
				count++;
			}
			a += d;
		}

		cout << primenum[flag] << endl;
	}

	return 0;
}
 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章