POJ1589 ZOJ1324 UVA400 UVALive5484 Unix ls【排序+文本處理】

Unix ls

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2876   Accepted: 967

Description

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function. 
Your program will eventually read input from a pipe (although for now your program will read from the input). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right. 
 

Input

The input will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 <= N <= 100). There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set { ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty. 

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input. 

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

Sample Output

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter

Source

South Central USA 1995

 

Regionals 1995 >> North America - South Central USA

 

問題鏈接POJ1589 ZOJ1324 UVA400 UVALive5484 Unix ls

問題描述:(略)

問題分析

  在文本界面時代,一個目錄下的目錄和文件需要顯示,並且按照一定的格式進行顯示。這個題就是解決這樣的問題的。

  需要顯示的文件名需要排序一下。

  這個題的關鍵是計算總共的行數和列數,本來需要考慮能否整除的問題,如果用條件判斷來做邏輯清晰,但是描述繁瑣,找出一個計算公式來並且用一個表達式來描述計算就簡潔了。

程序說明

  這個程序在ZOJ1324中出現PE,只能說ZOJ的測試數據與衆不同,也許是考慮了特殊的情況?

參考鏈接:(略)

題記:用表達式描述一個計算是最簡潔的方式。

 

AC的C++語言程序(ZOJ1324中PE)如下:

/* POJ1589 ZOJ1324 UVA400 UVALive5484 Unix ls */

#include <iostream>
#include <algorithm>

using namespace std;

const int COL = 60;
const int N = 100;
string fn[N];

// 輸出字符串s,補足空格使之長度爲len
void print(const string& s, int len, char extra)
{
    cout << s;
    len -= s.length();
    while(len--)
        cout << extra;
}

int main()
{
    int n;
    while(cin >> n) {
        int maxlen = 0;
        for(int i = 0; i < n; i++) {
            cin >> fn[i];
            maxlen = max(maxlen, (int)fn[i].length());
        }

        // 計算行數rows和列數cols
        int cols = (COL - maxlen) / (maxlen + 2) + 1;
        int rows = (n - 1) / cols + 1;

        // 輸出結果:先按字典順序排序
        sort(fn, fn + n);
        print("", COL, '-');
        cout << endl;
        for(int i = 0; i < rows; i++) {
            for(int j = 0; j < cols; j++) {
                int idx = j * rows + i;
                if(idx < n)
                    print(fn[idx], j == cols - 1 ? maxlen : maxlen + 2, ' ');
                else
                    break;
            }
            cout << endl;
        }
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章