poj1942Paths on a Grid

Paths on a Grid
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21503   Accepted: 5284

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

其實就是求C(n+m,min(n,m))。重點是怎麼求:用C(n,k+1)=C(n,k)*(n-k) / (k+1); 直接從C(n,0)推算出來。由於答案不會大於2^32,所以不會爆long long
代碼:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#define MOD 1000000009
using namespace std;
int main()
{
    long long n,m,c;
    while(scanf("%I64d %I64d",&n,&m)&&(n||m))
    {
        c=1;
        for(long long i=1;i<=min(n,m);i++)
        {
            c=c*(m+n-i+1)/i;
        }
        printf("%I64d\n",c);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章