UVA-1152 (二分) 4 Values whose Sum is 0

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d) ∈ A × B × C × D are such that a + b + c + d = 0. In the following, we assume that all lists have the same size n. Input The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive

inputs.

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228) that belong respectively to A, B, C and D.

Output

For each test case, your program has to write the number quadruplets whose sum is zero. The outputs of two consecutive cases will be separated by a blank line.

Sample Input

1

6

-45 22 42 -16

-41 -27 56 30

-36 53 -37 77

-36 30 -75 -46

26 -38 -10 62

-32 -54 -6 45

Sample Output

5

Sample Explanation:

Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46), (-32, 30, -75, 77), (-32, -54, 56, 30).

#include<iostream>
#include<cstdio>
#include<algorithm>
#define N 4010
#define M 25000000
using namespace std;
int n,a[N],b[N],c[N],d[N],ans,s1[M],s2[M],k;
void init() {
	ans=0;
	k=0;
	for(int i=0; i<n; i++)
		for(int j=0; j<n; j++) {
			s1[k]=a[i]+b[j];
			s2[k]=c[i]+d[j];
			k++;
		}
	sort(s2,s2+k);
	for(int i=0; i<k; i++) {
		int t=s1[i];
		int left=0,right=k-1;
		while(left<=right) {
			int mid=(right+left)/2;
			if(s2[mid]==-t) {
				ans++;
				int p1=mid,p2=mid;//查重 
				while(s2[++p1]==-t&&p1<k) ans++;
				while(s2[--p2]==-t&&p2>=0)ans++;
				break;//處理完及時跳出 
			} else if(s2[mid]<-t) left=mid+1;
			else right=mid-1;
		}
	}
	printf("%d\n",ans);
}
int main() {
	int t;
	scanf("%d",&t);
	while(t--) {
		scanf("%d",&n);
		for(int i=0; i<n; i++)
			scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
		init();
		if(t)
			printf("\n");
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章