UVA-1605 Building for UN

The United Nations has decided to build a new headquarters in Saint Petersburg, Russia. It will have a form of a rectangular parallelepiped and will consist of several rectangular floors, one on top of another. Each floor is a rectangular grid of the same dimensions, each cell of this grid is an office. Two offices are considered adjacent if they are located on the same floor and share a common wall, or if one’s floor is the other’s ceiling. The St. Petersburg building will host n national missions. Each country gets several offices that form a connected set. Moreover, modern political situation shows that countries might want to form secret coalitions. For that to be possible, each pair of countries must have at least one pair of adjacent offices, so that they can raise the wall or the ceiling they share to perform secret pair-wise negotiations just in case they need to. You are hired to design an appropriate building for the UN.

Input

Input consists of several datasets. Each of them has a single integer number n (1 ≤ n ≤ 50) — the number of countries that are hosted in the building.

Output

On the first line of the output for each dataset write three integer numbers h, w, and l — height, width and length of the building respectively. h descriptions of floors should follow. Each floor description consists of l lines with w characters on each line. Separate descriptions of adjacent floors with an empty line. Use capital and small Latin letters to denote offices of different countries. There should be at most 1 000 000 offices in the building. Each office should be occupied by a country. There should be exactly n different countries in the building. In this problem the required building design always exists. Print a blank line between test cases.

Sample Input

4

Sample Output

2 2 2

AB

CC

 

zz

zz

/*
有一種情況是一共只有兩層,
每層都是n*n的,
第一層的第i行全是國家i,
第二層的第j列全是國家j。 
*/
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
char a[55],b[55][55],c[55][55];
void init() {
	for(int i=1; i<=26; i++)
		a[i]=i-1+'a';
	for(int i=27; i<=53; i++)
		a[i]=i-27+'A';
	for(int i=1; i<=53; i++)
		for(int j=1; j<=53; j++) {
			b[i][j]=a[i];
			c[j][i]=a[i];
		}
}
int main() {
	int n;
	init();
	while(~scanf("%d",&n)) {
		printf("2 %d %d\n",n,n);
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=n; j++)
				printf("%c",b[i][j]);
			printf("\n");
		}
		printf("\n");
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=n; j++)
				printf("%c",c[i][j]);
			printf("\n");
		}
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章