hpuvj【3070】Fibonacci(矩陣快速冪求模)



Time Limit: 1000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

 Status

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source


一道涉及到矩陣快速冪的知識的題 本來快速冪沒學好 今天還專門說這個了,所以 看了半天才略懂了 一些,代碼如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Mat//定義矩陣
{
	int a[2][2];
	void init()
	{
		memset(a,0,sizeof(a));
		a[0][0]=a[1][1]=1;
	 } 
};
Mat mul(Mat a,Mat b)//矩陣乘法 
{
	Mat ans;
	ans.init();
	for(int i=0;i<2;i++)
	{
		for(int j=0;j<2;j++)
		{
			ans.a[i][j]=0;
			for(int k=0;k<2;k++)
            {
                ans.a[i][j]+=a.a[i][k]*b.a[k][j];
            }
            ans.a[i][j]%=10000;
		}
	}
	return ans;
}
Mat power(Mat a,int num)//矩陣快速冪模板 
{
	Mat ans;
	ans.init();
	while(num)
	{
		if(num%2==1)
		{
			ans=mul(ans,a);
		}
		num/=2;
		a=mul(a,a);
	}
	return ans;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF&&n!=-1)
	{
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		Mat a,ans;
		a.a[0][1]=a.a[0][0]=a.a[1][0]=1;
		a.a[1][1]=0;
		ans=power(a,n);
		printf("%d\n",ans.a[0][1]%10000);
	}
	return 0;
}


Time Limit: 1000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

 Status

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章