hdu1212 Big Number

 

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2920    Accepted Submission(s): 1984

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

 

Output
For each test case, you have to ouput the result of A mod B.
 

 

Sample Input
2 3 12 7 152455856554521 3250
 

 

Sample Output
2 5 1521
 

 

Author
Ignatius.L
 

 

Source
 

 

Recommend
Eddy
 

 

累加求模

 

  1. #include<stdio.h> 
  2.  
  3. int main(){ 
  4.     char str[2000]; 
  5.     int i,x,n; 
  6.     while(scanf("%s%d",str,&x)!=EOF){ 
  7.         i=n=0; 
  8.         for(i;str[i];i++) 
  9.             n=(n*10+str[i]-48)%x; 
  10.         printf("%d\n",n); 
  11.     } 
  12.     return 0; 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章