ADSL PPPOE+NAT+mGRE+NHRP+EIGRP+IPsec ***+PPTP *** 組成DM*** 實現動態IP 之間全網互通(二)

SZ Router
SZRouterr#sh startup-config
Using 4236 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SZRouter
!
boot-start-marker
boot-end-marker
!

logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$BO0.$ThLOZpH1897qNXG.Y6FGr.
!
no aaa new-model
!
no dot11 syslog
no ip source-route
!
!
ip cef
!
!
ip name-server 210.21.196.6
ip name-server 221.5.88.88
!
multilink bundle-name authenticated
!−−− 開啓PPPOE 撥號服務
vpdn enable
!
!
!
!
!
!
username szrouter privilege 15 secret 5 $1$oaFo$sPaJb3sWhF36PpF749qs5/
archive
log config
hidekeys
!
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac
!
crypto ipsec profile Cisco
set security-association lifetime seconds 120
set transform-set strong
!
!
!
!
!
!
!
interface Tunnel1
ip address 20.90.1.2 255.255.0.0
no ip redirects
ip mtu 1440
ip nhrp authentication 12345678
ip nhrp map multicast dynamic
ip nhrp map 20.90.1.1 50.1.1.1
ip nhrp map multicast 50.1.1.1
ip nhrp network-id 1
ip nhrp nhs 20.90.1.1
tunnel source Dialer1
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile Cisco
!
interface FastEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ES_WAN$
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description $ES_LAN$
ip address 20.88.1.2 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 12345678 password 0 12345678
!
router eigrp 1
network 20.88.0.0 0.0.255.255
network 20.90.0.0 0.0.255.255
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 20.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.
It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.
username <myuser> privilege 15 secret 0 <mypassword>
Replace <myuser> and <mypassword> with the username and password you want to
use.
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.
YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE PUBLICLY-KNOWN
CREDENTIALS
Here are the Cisco IOS commands.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want
to use.
IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
password cisco
login
line aux 0
line vty 0 4
privilege level 15
password cisco
login
transport input telnet
!
scheduler allocate 20000 1000
end


Shanghai Router
SHRouter#sh startup-config
Using 4575 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SHRouter
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$A74C$cokK2B7ZIc6Dnj.T/OY1j1
!
no aaa new-model
!
no dot11 syslog
no ip source-route
!
!
ip cef
ip dhcp excluded-address 20.87.5.1 20.87.5.255
ip dhcp excluded-address 20.87.4.0
ip dhcp excluded-address 20.87.0.1 20.87.3.255
!
ip dhcp pool SHDHCP
network 20.87.0.0 255.255.0.0
dns-server 20.87.1.2
default-router 20.87.1.2
option 156 ascii "ftpservers=20.88.2.2,country=1,language=1,layer2tagging=0,vlanid=0"
option 4 ip 20.88.2.1
lease 30
!
!
ip name-server 116.228.111.118
ip name-server 180.168.255.18
!
multilink bundle-name authenticated
!
vpdn enable
!
!
!
!
!
!
username shrouter privilege 15 secret 5 $1$UOf2$3fS8iYrlPz82MHem0lPX40
archive
log config
hidekeys
!
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac
!
crypto ipsec profile Cisco
set security-association lifetime seconds 120
set transform-set strong
!
!
!
!
!
!
interface Tunnel1
ip address 20.90.1.4 255.255.0.0
no ip redirects
ip mtu 1440
ip nhrp authentication 12345678
ip nhrp map multicast dynamic
ip nhrp map 20.90.1.1 50.1.1.1
ip nhrp map multicast 50.1.1.1
ip nhrp network-id 1
ip nhrp nhs 20.90.1.1
tunnel source Dialer1
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile Cisco
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 20.87.1.2 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 12345678 password 0 12345678
!
router eigrp 1
network 20.87.0.0 0.0.255.255
network 20.90.0.0 0.0.255.255
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.
It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.
username <myuser> privilege 15 secret 0 <mypassword>
Replace <myuser> and <mypassword> with the username and password you want to
use.
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.
YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE PUBLICLY-KNOWN
CREDENTIALS
Here are the Cisco IOS commands.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want
to use.
IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
password cisco
login
line aux 0
line vty 0 4
privilege level 15
password cisco
login
transport input telnet
!
scheduler allocate 20000 1000
end


Beijing Router
BJRouter#sh startup-config
Using 4574 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BJRouter
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$IXeF$Pw72XJvTH/buTD6fHZ2c10
!
no aaa new-model
!
no dot11 syslog
no ip source-route
!
!
ip cef
ip dhcp excluded-address 20.86.0.1 10.86.3.255
ip dhcp excluded-address 20.86.5.1 10.86.5.255
ip dhcp excluded-address 20.86.4.0
!
ip dhcp pool BJDHCP
network 20.86.0.0 255.255.0.0
dns-server 20.86.1.2
default-router 20.86.1.2
option 156 ascii "ftpservers=20.88.2.2,country=1,language=1,layer2tagging=0,vlanid=0"
option 4 ip 20.88.2.1
lease 30
!
!
ip name-server 202.106.195.68
ip name-server 202.106.0.20
!
multilink bundle-name authenticated
!
vpdn enable
!
!
!
!
!
!
username bjrouter privilege 15 secret 5 $1$96O2$PdfZUZ/eu3oNSk140Y9b51
archive
log config
hidekeys
!
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac
!
crypto ipsec profile Cisco
set security-association lifetime seconds 120
set transform-set strong
!
!
!
!
!
!
interface Tunnel1
ip address 20.90.1.3 255.255.0.0
no ip redirects
ip mtu 1440
ip nhrp authentication 12345678
ip nhrp map multicast dynamic
ip nhrp map 20.90.1.1 50.1.1.1
ip nhrp map multicast 50.1.1.1
ip nhrp network-id 1
ip nhrp nhs 20.90.1.1
tunnel source Dialer1
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile Cisco
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 20.86.1.2 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 12345678 password 0 12345678
!
router eigrp 1
network 20.86.0.0 0.0.255.255
network 20.90.0.0 0.0.255.255
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 20.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.
It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.
username <myuser> privilege 15 secret 0 <mypassword>
Replace <myuser> and <mypassword> with the username and password you want to
use.
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.
YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE PUBLICLY-KNOWN
CREDENTIALS
Here are the Cisco IOS commands.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want
to use.
IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
password cisco
login
line aux 0
line vty 0 4
privilege level 15
password cisco
login
transport input telnet
!
scheduler allocate 20000 1000
end

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章