HDU 1014 Uniform Generator

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form
seed(x+1) = [seed(x) + STEP] % MOD
where ‘%’ is the modulus operator.
Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.
For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.
If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.
Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.
Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.
Sample Input
3 5
15 20
63923 99999
Sample Output
3 5 Good Choice
15 20 Bad Choice
63923 99999 Good Choice

//順便吐槽一句新版代碼高亮顏色好醜

我的暴力解法:

#include<iostream>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<vector>
using namespace std;
const int INF=100005;
int STEP,MOD;
bool a[INF];
int seed[INF];
int main()
{
	while(cin>>STEP>>MOD)
	{
		memset(a,false,sizeof(a));
		int i=0;
		a[seed[i]]=true;
		while(1)
		{
			seed[i+1]=(seed[i]+STEP)%MOD;
			i++;
			a[seed[i]]=true;//出現過變爲true
			if(seed[i]==0)
				break;
		}
		int j;
		for(j=0;j<MOD;j++)//循環判斷0~MOD-1之間有沒有沒出現過的值
		{
			if(a[j]==false)
			{
				printf("%10d%10d    Bad Choice\n\n",STEP,MOD);
				//cout<<setw(10)<<STEP<<setw(10)<<MOD<<"    Bad Choice"<<endl;
				break;
			}
		}
		if(j==MOD)
			printf("%10d%10d    Good Choice\n\n",STEP,MOD);
			//cout<<setw(10)<<STEP<<setw(10)<<MOD<<"    Good Choice"<<endl;
	}
return 0;
}

網上題解gcd代碼(原理沒看懂):

#include<iostream>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<vector>
using namespace std;
const int INF=100005;
int STEP,MOD;
bool a[INF];
int seed[INF];
int gcd(int a,int b)
{
	return b==0?a:gcd(b,a%b);
}
int main()
{
	while(cin>>STEP>>MOD)
	{
		if(gcd(STEP,MOD)==1)
		{
			printf("%10d%10d    Good Choice\n\n",STEP,MOD);
			//cout<<setw(10)<<STEP<<setw(10)<<MOD<<"    Bad Choice"<<endl;
		}
		else
			printf("%10d%10d    Bad Choice\n\n",STEP,MOD);
			//cout<<setw(10)<<STEP<<setw(10)<<MOD<<"    Good Choice"<<endl;
	}
return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章