C - How do you add

Larry is very bad at math — he usually uses a calculator, which worked well throughout college. Unforunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident. They’re now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you! It’s a very simple problem — given a number N, how many ways can K numbers less than N add up to N? For example, for N = 20 and K = 2, there are 21 ways: 0+20 1+19 2+18 3+17 4+16 5+15 ... 18+2 19+1 20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K, print a single number mod 1,000,000 on a single line.
Sample Input
20 2 20 2 0 0
Sample Output
21 21

https://www.cnblogs.com/pixiuart/p/5976817.html

上面可以複習高中相關知識

#include<bits/stdc++.h>
using namespace std;
const int n=210;
const int remain=1000000;
int a[n+1][n+1];
int initialize()
{
    a[0][0]=1;
    for(int i=1;i<=n;i++)
    {
        a[i][0]=1;
        for(int j=1;j<n;j++)
        {
            a[i][j]=(a[i-1][j]%remain+a[i-1][j-1]%remain)%remain;
        }
        a[i][n]=1;

    }
    return 0;
}
int main()
{
    int m,k;
    initialize();
    while(cin>>m>>k&&(m||k))
    {
        cout<<a[m+k-1][k-1]<<endl;
    }
    return 0;
}

這道題一開始我是沒怎麼看懂題目。我想的是相當於相同的1放在不同的盒子裏,可以爲空,但是後來想錯了,先放一個1在每個n 的1裏,保證不爲0,但是不是清晰的分組了。只有組數確定的情況下,纔可以這樣做。

由於可以爲0,相當於兩個個板子中間沒東西,就想到直接選元素,可相鄰,可分開,於是放進原來n個元素。變成n+k-1個元素,選擇k-1個即可。找的是共同具有的性質,再抽象轉化。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章