hdu_problem_2057_A + B Again

題目大意:輸入兩個16進制數,輸出相加的結果

/*
*
*Problem Description
*There must be many A + B problems in our HDOJ , now a new one is coming.
*Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
*Easy ? AC it !
*
*
*Input
*The input contains several test cases, please process to the end of the file.
*Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
*The length of A and B is less than 15.
*
*
*Output
*For each test case,print the sum of A and B in hexadecimal in one line.
*
*
*Sample Input
*+A -A
*+1A 12
*1A -9
*-1A -12
*1A -AA
*
*
*Sample Output
*0
*2C
*11
*-2C
*-90
*
*
*Author
*linle
*
*
*Source
*校慶杯Warm Up
*
*
*Recommend
*linle
*
*/
#include<iostream>
#include<cmath>
#include<string>
using namespace std;
long long a, b;
int length;
long long htod(string s) {
 long long temp(0);
 length = s.size();
 for (int i = s.size() - 1; i >= 0; --i) {
  if ('A' <= s.at(i) && s.at(i) <= 'Z') {
   temp += (s.at(i) - 'A' + 10)*pow(16, length - i - 1);
  }
  else if (s.at(i) == '-') {
   temp = -temp;
  }
  else if (s.at(i) == '+') {
   continue;
  }
  else {
   temp += (s.at(i) - '0')*pow(16, length - i - 1);
  }
 }
 return temp;
}
int main() {
 string A, B;
 while (cin >> A >> B) {
  a = htod(A);
  b = htod(B);
  if (a + b >= 0)
   printf("%llX\n", a + b);
  else
   printf("-%llX\n",-(a + b));
 }
 system("pause");
 return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章