hdu_problem_2070_Fibbonacci Number

/*
*Problem Description
*Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:
*
*f(0) = 0
*f(1) = 1
*f(n) = f(n-1) + f(n-2)
*
*Your program should be able to handle values of n in the range 0 to 50.
*
*
*Input
*Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
*
*
*Output
*Print out the answer in a single line for each test case.
*
*
*Sample Input
*3
*4
*5
*-1
*
*
*Sample Output
*2
*3
*5
*
*Hint
*Note:
*
*you can use 64bit integer: __int64
*
*
*Author
*Lily
*
*
*Source
*浙江工業大學網絡選拔賽
*
*
*Recommend
*linle
*
*/
#include<iostream>
using namespace std;
_int64 fb_num[51] = { 0,1 };
void init() {
 for (int i = 2; i < 51; ++i) {
  fb_num[i] = fb_num[i - 1] + fb_num[i - 2];
 }
}
int main() {
 int x;
 init();
 while (cin >> x) {
  if (x == -1) break;
  cout << fb_num[x] << endl;
 }
 system("pause");
 return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章