hdu_problem_2058_The sum problem

題目大意:給定一個序列1,2,3, ,N1,2,3,\cdots,N然後給一個數字M,計算該序列的子序列中加起來等於M的情況並輸出。
輸入:N和M。
輸出:輸出一個區間,該區間包含的子序列之和等於M,每種情況最後加上一個空行
方法:直接暴力求解會超時QAQ,所以需要用等差數列求和公式

Sn=d2n2+(a1d2)nS_n = \frac{d}{2}n^2 +(a_1 - \frac{d}{2})n 可以得到 a1=Snn(n1)2na_1 = \frac{S_n-\frac{n(n-1)}{2}}{n}

每次只需要算出a1a_1然後再把a1a_1帶入到公式中看是否相等就可以了,並且由等差數列公式可以知道1<=n<=2Sn1<=n<=\sqrt{2S_n}

/*
*
*Problem Description
*Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
*
*
*Input
*Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
*
*
*Output
*For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
*
*
*Sample Input
*20 10
*50 30
*0 0
*
*
*Sample Output
*[1,4]
*[10,10]
*
*[4,8]
*[6,9]
*[9,11]
*[30,30]
*
*
*Author
*8600
*
*
*Source
*校慶杯Warm Up
*
*
*Recommend
*linle
*
*/
#include<iostream>
using namespace std;
int main() {
 int N, M, temp;
 while (cin >> N >> M) {
  if (N == 0 && M == 0) break;
  for (int i = sqrt(2 * M); i >= 1; --i) {
   temp = (M - (i - 1)*i / 2) / i;
   if (temp*i + (i - 1)*i / 2 == M) {
    printf("[%d,%d]\n", temp, temp + i - 1);
   }
  }
  cout << endl;
 }
 system("pause");
 return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章