Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

題意:n行,m列,*代表土地,@代表油田,可以連通的油田裏面是同一種油,問一共有幾種不同的油?注意,油田的連通方向是八個方向;

思路:用二維數組存圖,在遍歷圖的過程中,發現@計數器加一,然後以發現的@的x與y座標開始深搜,在深搜過程中,只要搜到@就把他變成*,這樣與計數器加一有關的@以及相關聯的@都變成了*,這就發現了完整的一塊油田,最後輸出計數器的值就行了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m;
int ans;
char mp[105][105];
int pos[8][2]= {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
void dfs(int x,int y) {
	int i;
	mp[x][y]='*';//搜完就記爲*
	int tx,ty;
	for(i=0; i<8; i++) {
		tx=x+pos[i][0];
		ty=y+pos[i][1];
		if(tx>-1&&tx<n&&ty>-1&&ty<m) {
			if(mp[tx][ty]=='@')
				dfs(tx,ty);
		}
	}
}
int main() {
	while(scanf("%d%d",&n,&m)!=EOF) {
		if(n==0&&m==0)break;
		int i,j;
		for(i=0; i<n; i++) {
			scanf("%s",mp[i]);
			getchar();
		}
		ans=0;
		for(i=0; i<n; i++) {
			for(j=0; j<m; j++) {
				if(mp[i][j]=='@') {
					ans++;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章