1007 Maximum Subsequence Sum(在線處理)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

題意:求最大子列和,輸出最大的子列和,子列的第一項,子列的最後一項;若序列全爲負數,輸出0,序列第一項,序列最後一項。

在在線處理求最大子列和的基礎上記錄最大子列和的首尾兩個位置。

代碼:

#include<iostream>
using namespace std;
int a[10005];
int main() {
	int N;
	cin>>N;
	for (int i = 0; i < N; i++) {
		cin>>a[i];
	}
	//sum爲子列和,MAX爲最大子列和,first記錄子列和的第一項,src爲最大子列和的第一項,end爲最大子列和的最後一項
	int sum=0,first=0,src=N-1,end=N-1,max=-1;
	for (int i=0; i<N; i++) {
		sum+=a[i];
		//當前子列和>最大子列和時修改MAX,即SUM>MAX時,將max = sum.
		if (sum>max) {
			max=sum;
			src=first;
			end=i;
		}
		//sum<0時重置sum,first
		if(sum <0) {
			first=i+1;
			sum=0;
		}
	}
	if (max<0) cout<<0<<' '<<a[0]<<' '<<a[N-1];
	else cout <<max<<' '<<a[src]<<' '<<a[end];
	return 0;
}

 

//在線處理求序列的最大子列和
#include<iostream>
#include<cstdio>
using namespace std;
int k[100005];
int SumMax(int a[],int n){
int maxsum=0,thissum=0;
for(int i=0;i<n;i++){
thissum+=a[i];
if(thissum>maxsum)
maxsum=thissum;
else if(thissum<0)
thissum=0;
}
return maxsum;
} 
int main(){
int n;
cin>>n;
for(int i=0;i<n;i++){
scanf("%d",&k[i]);
}
int max=SumMax(k,n);
printf("%d",max);
return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章