Cisco交换机配置命令

switch(config)# hostname hostname

在基于CLI的交换机上设置主机名/系统名:

switch(enable) set system name name-string


2.在基于IOS的交换机上设置登录口令:

switch(config)# enable password level 1password

在基于CLI的交换机上设置登录口令:

switch(enable) set password

switch(enable) set enalbepass


3.在基于IOS的交换机上设置远程访问:

switch(config)# interface vlan 1

switch(config-if)# ip address ip-addressnetmask

switch(config-if)# ip default-gatewayip-address

在基于CLI的交换机上设置远程访问:

switch(enable) set interface sc0 ip-addressnetmask broadcast-address

switch(enable) set interface sc0 vlan

switch(enable) set ip route default gateway


4.在基于IOS的交换机上启用和浏览CDP信息:

switch(config-if)# cdp enable

switch(config-if)# no cdp enable

为了查看Cisco邻接设备的CDP通告信息:

switch# show cdp interface [type modle/port]

switch# show cdp neighbors [typemodule/port] [detail]

在基于CLI的交换机上启用和浏览CDP信息:

switch(enable) set cdp {enable|disable}module/port

为了查看Cisco邻接设备的CDP通告信息:

switch(enable) show cdpneighbors[module/port] [vlan|duplex|capabilities|detail]


5.基于IOS的交换机的端口描述:

switch(config-if)# descriptiondescription-string

基于CLI的交换机的端口描述:

switch(enable)set port name module/numberdescription-string


6.在基于IOS的交换机上设置端口速度:

switch(config-if)# speed{10|100|auto}

在基于CLI的交换机上设置端口速度:

switch(enable) set port speed moudle/number{10|100|auto}

switch(enable) set port speed moudle/number{4|16|auto}


7.在基于IOS的交换机上设置以太网的链路模式:

switch(config-if)# duplex {auto|full|half}

在基于CLI的交换机上设置以太网的链路模式:

switch(enable) set port duplexmodule/number {full|half}


8.在基于IOS的交换机上配置静态VLAN:

switch# vlan database

switch(vlan)# vlan vlan-num name vla


switch(vlan)# exit

switch# configure teriminal

switch(config)# interface interfacemodule/number

switch(config-if)# switchport mode access

switch(config-if)# switchport access vlanvlan-num

switch(config-if)# end

在基于CLI的交换机上配置静态VLAN:

switch(enable) set vlan vlan-num [namename]

switch(enable) set vlan vlan-nummod-num/port-list


9. 在基于IOS的交换机上配置VLAN中继线:

switch(config)# interface interfacemod/port

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunkencapsulation {isl|dotlq}

switch(config-if)# switchport trunk allowedvlan remove vlan-list

switch(config-if)# switchport trunk allowedvlan add vlan-list

在基于CLI的交换机上配置VLAN中继线:

switch(enable) set trunk module/port[on|off|desirable|auto|nonegotiate]

Vlan-range [isl|dotlq|dotl0|lane|negotiate]


10.在基于IOS的交换机上配置VTP管理域:

switch# vlan database

switch(vlan)# vtp domain domain-name

在基于CLI的交换机上配置VTP管理域:

switch(enable) set vtp [domain domain-name]


11.在基于IOS的交换机上配置VTP 模式:

switch# vlan database

switch(vlan)# vtp domain domain-name

switch(vlan)# vtp{sever|cilent|transparent}

switch(vlan)# vtp password password

在基于CLI的交换机上配置VTP 模式:

switch(enable) set vtp [domain domain-name][mode{ sever|cilent|transparent }][password password]


12. 在基于IOS的交换机上配置VTP版本:

switch# vlan database

switch(vlan)# vtp v2-mode

在基于CLI的交换机上配置VTP版本:

switch(enable) set vtp v2 enable


13. 在基于IOS的交换机上启动VTP剪裁:

switch# vlan database

switch(vlan)# vtp pruning

在基于CL I 的交换机上启动VTP剪裁:

switch(enable) set vtp pruning enable


14.在基于IOS的交换机上配置以太信道:

switch(config-if)# port group group-number[distribution {source|destination}]

在基于CLI的交换机上配置以太信道:

switch(enable) set port channelmoudle/port-range mode{on|off|desirable|auto}


15.在基于IOS的交换机上调整根路径成本:

switch(config-if)# spanning-tree [vlanvlan-list] cost cost

在基于CLI的交换机上调整根路径成本:


switch(enable) set spantree portcostmoudle/port cost

switch(enable) set spantree portvlancostmoudle/port [cost cost][vlan-list]


16.在基于IOS的交换机上调整端口ID:

switch(config-if)# spanning-tree[vlanvlan-list]port-priority port-priority

在基于CLI的交换机上调整端口ID:

switch(enable) set spantree portpri{mldule/port}priority

switch(enable) set spantree portvlanpri{module/port}priority [vlans]


17. 在基于IOS的交换机上修改STP时钟:

switch(config)# spanning-tree [vlanvlan-list] hello-time seconds

switch(config)# spanning-tree [vlanvlan-list] forward-time seconds

` switch(config)# spanning-tree [vlanvlan-list] max-age seconds

在基于CLI的交换机上修改STP时钟:

switch(enable) set spantree hello interval[vlan]

switch(enable) set spantree fwddelay delay[vlan]

switch(enable) set spantree maxageagingtiame[vlan]


18. 在基于IOS的交换机端口上启用或禁用PortFast 特征:

switch(config-if)#spanning-tree portfast

在基于CLI的交换机端口上启用或禁用Port Fast 特征:

switch(enable) set spantree portfast{module/port}{enable|disable}


19. 在基于IOS的交换机端口上启用或禁用UplinkFast特征:

switch(config)# spanning-tree uplinkfast[max-update-rate pkts-per-second]

在基于CLI的交换机端口上启用或禁用UplinkFast 特征:

switch(enable) set spantree uplinkfast{enable|disable}[rate update-rate] [all-protocols off|on]


20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令:switch(config)# cluster enable cluster-name


21. 为了从一条中继链路上删除VLAN,可使用下列命令:

switch(enable) clear trunk module/portvlan-range


22. 用show vtp domain 显示管理域的VTP参数.


23. 用show vtp statistics显示管理域的VTP参数.


24. 在Catalyst交换机上定义TrBRF的命令如下:

switch(enable) set vlan vlan-name [namename] type trbrf bridge bridge-num[stp {ieee|ibm}]


25. 在Catalyst交换机上定义TrCRF的命令如下:

switch (enable) set vlan vlan-num [namename] type trcrf

{ring hex-ring-num|decringdecimal-ring-num} parent vlan-num


26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:

switch(enable) set vlan vlan-nummod-num/port-num


27. 命令show spantree显示一个交换机端口的STP状态.



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章