hdu - 4405 Aeroplane chess

Problem Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

 

 

Input

There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.

 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

Sample Input

2 0

8 3

2 4

4 5

7 8

0 0

Sample Output

1.1667

2.3441

思路:

概率dp。

dp[i]表示從i到終點的期望,如果從i點可以直接跳到j,則dp[i] = dp[j],否則dp[i] = 1 + (1/6)*sum(dp[i+j]); j = 1, 2, ... 6。

#include<cmath>
#include<cstdio>
#include<cstring>
using namespace std;
 
const int MAXN = 110000;
 
double dp[MAXN];
int path[MAXN], n, m;
 
int main()
{
   while (~scanf("%d%d",&n,&m) && (n+m))
   {
       memset(path, -1, sizeof(path));
       for (int i=1; i <= m; i++)
       {
           int a,b;
           scanf("%d%d", &a, &b);
           path[a] = b; 
       }

       for (int i = n; i >= 1; i--)
       {
           if (path[i] != -1)
           {
               int j = path[i];
               if (path[j] != -1)
			   {
                    path[i] = path[j];
			   }
           }
       }
       for (int i = 0; i < 6; i++)
	   {
            dp[n + i] = 0;
	   }

       for (int i = n-1; i >= 0; i--)
       {
           if (path[i]!=-1)
		   {
               dp[i] = dp[path[i]];
		   }
           else
           {
               double temp = 0;
               for (int j = 1; j <= 6; j++)
               {
                   temp += dp[i+j] * (1.0/6.0);
               }
               dp[i] = 1 + temp;
           }
       }

       printf("%.4f\n", dp[0]);
   }

   return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章