A - Bi-shoe and Phi-shoe LightOJ - 1370

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

題意:Φ (n)表示長度爲小於數字n的和n互質的數的個數,也就是歐拉函數。現在給出n個幸運數字,對於每一個幸運數字,要求的x,使Φ (x)的值大於等於這個幸運數字,求這些x和的最小值
知識點:素數打表(埃氏篩法),歐拉函數的性質
暫時還沒出證明會不會存在x不是素數也能使題意成立,所以這樣的解法還不能讓我信服
在這裏插入圖片描述

#include<iostream>
#define maxn 1000010
using namespace std;
int T;
int n,num;
int p[maxn]={0};
void find_prime(){
    for(int i=2;i<maxn;i++){
        if(p[i]==false){
            for(int j=i+i;j<maxn;j=j+i){
                p[j]=true;
            }
        }
    }
}
int main(){
    cin>>T;
    find_prime();
    for(int i=1;i<=T;i++){
        cin>>n;
        long long int ans=0;
        for(int j=0;j<n;j++){
            cin>>num;
            for(int k=num+1;k<maxn;k++){
                if(p[k]==false){
                    ans+=k;
                    break;
                }
            }
        }
        cout<<"Case "<<i<<": "<<ans<<" Xukha"<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章