sgu - 495 Kids and Prizes

ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected M winners. There are Nprizes for the winners, each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:

  • All the boxes with prizes will be stored in a separate room.
  • The winners will enter the room, one at a time.
  • Each winner selects one of the boxes.
  • The selected box is opened by a representative of the organizing committee.
  • If the box contains a prize, the winner takes it.
  • If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).
  • Whether there is a prize or not, the box is re-sealed and returned to the room.

The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number of prizes given (the certificates are not counted as prizes, of course).
 

Input

The first and only line of the input file contains the values of N and M ().
 

Output

The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10-9.
 

Example(s)

sample input
sample output
5 7
3.951424

 

sample input
sample output
4 3
2.3125

思路:

對於每個禮品,它被選中的概率是p1 = 1 - ((n-1)/n)^m;

一共有n個禮品,因此期望值是n * p1;

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;

int main()
{
    int n, m;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        double p = (double)(n-1)/n;
        double ans = n - n * pow(p, m);
        printf("%.10lf\n", ans);
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章