poj - 2151 Check the difficulty of problems

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

思路:

概率dp。

dp[i][j][k]表示第i個隊伍在前j道題中解出k道的概率。

dp[i][j][k] = dp[i][j-1][k-1] * p[i][j] +dp[i][j-1][k] * (1 - p[i][j])

s[i][j]表示第i個隊伍解出題目小於等於j個的概率。

s[i][j] = dp[i][M][0] + dp[i][M][1] + ... + dp[i][M][j];

每個隊伍至少解出一道題的概率:

p1 = (1 - s[1][0]) * (1 - s[2][0]) *... * (1 - s[T][0]);

每個隊伍解出題的數量均小於N的概率:

p2 = (s[1][N-1] - s[1][0]) * (s[2][N-1] - s[2][0]) * ... * (s[T][N-1] - s[T][0]);

答案是:p1 - p2

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
using namespace std;

const int MAXT = 1010;
const int MAXM = 40;

double dp[MAXT][MAXM][MAXM];
double s[MAXT][MAXM];
double p[MAXT][MAXM];

int main()
{
    int M,N,T;
    while (scanf("%d%d%d", &M, &T, &N) != EOF)
    {
        if (M == 0 && T == 0 && N == 0)
		{
			break;
		}
        for (int i = 1; i <= T; i++)
		{
            for (int j = 1; j <= M; j++)
			{
				scanf("%lf",&p[i][j]);
			}
		}

        for (int i = 1; i <= T; i++)
        {
			dp[i][0][0] = 1;
            for (int j = 1; j <= M; j++)
			{
				dp[i][j][0] = dp[i][j-1][0] * (1 - p[i][j]);
			}

            for (int j = 1; j <= M; j++)
			{
				for (int k = 1; k <= j; k++)
				{
					dp[i][j][k] = dp[i][j-1][k-1] * p[i][j] + dp[i][j-1][k] * (1 - p[i][j]);
				}
			}

            s[i][0] = dp[i][M][0];
            for (int k = 1; k <= M; k++)
			{
				s[i][k] = s[i][k-1] + dp[i][M][k];
			}
        }

        double P1 = 1;
        double P2 = 1;
        for (int i = 1; i <= T; i++)
        {
            P1 *= (1 - s[i][0]);
            P2 *= (s[i][N-1] - s[i][0]);
        }

        printf("%.3lf\n", P1 - P2);
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章