A1023 Have Fun with Numbers

 

A1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with kdigits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

注意要點:

  • 判斷下一位的進位時,上一位已經改變,所以必須使用temp來操作上一位,而且要用一個flag來保存進位的信息
  • 本題乘以2之後只會在0-19之間,所以直接減10就行
  • 比對是否是相同數字排列的技巧:book[10]記錄每個數字出現次數,全部爲0說明剛好對應上
  • 記得給flag初始化,提交能通過……但是dev和vs裏面過不了……
#include <iostream>
using namespace std;
int main(){
  string s;
  cin >> s;
  int len = s.length();
  int a[len];
  for(int i = 0; i < len; i++){
    a[i] = s[i] - '0';
  }
  int flag = 0;
  int book[10] = {0};
  for(int i = len - 1; i >= 0; i--){
    int temp = a[i];
    book[temp]++;
    temp = temp * 2 + flag;
    flag = 0;         //每次先要重置進位的標誌
    if(temp >= 10){
      temp = temp - 10;
      flag = 1;     //下一位進位的標誌
    }
    a[i] = temp;    //乘以2之後的數字
    book[temp]--;
  }
  int flag1 = 0;
  for(int i = 0; i < 10; i++){
    if(book[i] != 0)
      flag1 = 1;
  }
  if(flag == 1 || flag1 == 1)
    cout << "No" << endl;
  else
    cout << "Yes" << endl;
  if(flag == 1)
    cout << "1";
  for(int i = 0; i < len; i++){
    cout << a[i];
  }
  return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章