HDU1036 模擬 考察基礎

Average is not Fast Enough!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7418    Accepted Submission(s): 3123


 

Problem Description

A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.

 

 

Input

The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.

 

 

Output

For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.

 

 

Sample Input


 

2 12.5

5 0:23:21 0:25:01

42 0:23:32 -:--:--

7 0:33:20 0:41:35

 

 

Sample Output


 

5: 3:52 min/km

42: -

7: 6:00 min/km

 

 

Source

University of Ulm Local Contest 2001

 

 

Recommend

We have carefully selected several similar problems for you:  1031 1039 1037 1038 1032 

 

思路:輸入用字符串處理,然後提取出時間,轉化爲秒,重點來了,轉換爲秒後,以秒爲單位處以路程(這個地方要手動四捨五入),對結果取整,除以60取分鐘,對60取餘得到秒。

#include<iostream>
#include<cmath> 
using namespace std;
int main()
{
	int n,i,j;
	int name;
	char tem[10];
	double dis=0;
	scanf("%d %lf",&n,&dis);
	while(~scanf("%d",&name))
	{
		int f=0;
		int hour=0,min=0,sec=0;
		int s_t=0;
		double sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",tem);
			for(j=0;tem[j]!='\0';j++)
			{
				if(tem[j]=='-')
				{
					f=1;
					break;
				}
			}
			if(f==0)
			{
				hour=tem[0]-'0';
				min=(tem[2]-'0')*10+tem[3]-'0';
				sec=(tem[5]-'0')*10+tem[6]-'0';
				s_t=s_t+hour*3600+min*60+sec;
			}
		}
		if(f)
		{
			printf("%3d: -\n",name);
		}
		else
		{
			sum=sum+(double)s_t;
			double cnt=floor((double)(sum/dis+0.5));
			printf("%3d: %d:%02d min/km\n",name,(int)cnt/60,(int)cnt%60);
		}
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章