UVA440 POJ2244 Eeny Meeny Moo【約瑟夫環】

Eeny Meeny Moo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3704 Accepted: 2545

Description

Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow.
To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany’s cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order.
Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected.

Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

Input

The input will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country.
Input is terminated by a value of zero (0) for n.

Output

For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

Sample Input

3
4
5
6
7
8
9
10
11
12
0

Sample Output

2
5
2
4
3
11
2
3
8
16

Source

Ulm Local 1996

問題鏈接UVA440 POJ2244 Eeny Meeny Moo
問題簡述:(略)
問題分析
    電廠按照約瑟夫環的規則斷電,步長爲m,最後停在2號,求m。
    與參考鏈接基本上是同一個題,用暴力解法。
程序說明:(略)
參考鏈接UVA151 Power Crisis【數學】
題記:(略)

AC的C++語言程序如下:

/* UVA440 POJ2244 Eeny Meeny Moo */

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int n;
    while(~scanf("%d", &n) && n) {
        for(int i = 1; ; i++) {
            int k = 0;
            for(int j = 2; j < n; j++)
                k = (k + i) % j;
            if(k == 0) {
                printf("%d\n", i);
                break;
            }
        }
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章