Max Sum(hdu 1003)

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input


 

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

 

 

Sample Output


 

Case 1: 14 1 4 Case 2: 7 1 6

 

代碼如下:

代碼一(暴力):

#include<iostream>
using namespace std;

int main(){
    int t,n;
    int sum=0;

    cin>>t;
    while(t--){
        cin>>n;
        int *a=new int[n];
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        int maxsum=-999999;
        int start=0,end=0;
        for(int i=0;i<n;i++){
            sum=0;
            for(int j=i;j<n;j++){
                sum+=a[j];
                if(sum>maxsum){
                    maxsum=sum;
                    start=i;
                    end=j;
                }
            }
        }
        for(int i=1;i<=t;i++){
            cout<<"Case %d:"<<i<<endl;
        }
        cout<<maxsum<<" "<<start+1<<" "<<end+1<<endl;
         cout<<"\n"<<endl;
        delete[]a;
    }
    return 0;
}

代碼二(分治):

#include<stdio.h>
int main()
{
    int n,m,i,j,end,begin,temp,max;
    int e,f,k,flag=1;
    int a[100005];
    scanf("%d",&n);
    k=1;
    while(n--)
    {
        begin=end=0;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
        }
        temp=0;
        max=-999999;
        begin=e=1;
        f=1;
        for(i=1;i<=m;i++)
        {
            temp+=a[i];
            if(temp>max)
            {
                e=begin;
                f=i;
                max=temp;
            }
            if(temp<0)
            {
                begin=i+1;
                temp=0;
            }
        }
        printf("Case %d:\n",k++);
        printf("%d %d %d\n",max,e,f);
        if(n!=0)
            printf("\n");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章