HDU - 1011 Starship Troopers (樹形dp)

HDU1011

題目描述

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern’s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers – the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1’s.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1

Sample Output

50
7

題意

有n個蟻巢,m個士兵,每個士兵可以打20個螞蟻。
蟻巢是一個樹形結構,每個節點有一個螞蟻數和他有可能有蟻巢腦子的概率(即物品的價值),每個士兵通過殺死這個節點的所有螞蟻來獲得價值,不可以往回走,如果沒有螞蟻也需要有士兵路過這裏纔可以獲得價值。問獲得的最大價值。

我的理解

dp[i][j]表示第i棵樹爲根的子樹上有j個士兵是所獲得的最大價值。
dp關係式:
dp[i][j]=max(dp[i][j],dp[i][jk]+dp[son(i)][k])dp[i][j] = max(dp[i][j],dp[i][j-k]+dp[son(i)][k])
注意幾個地方:
1.如果沒有士兵直接輸出0。
2.如果一個葉子節點的螞蟻數爲0,那麼要給的消耗標記爲1,因爲只有有士兵走過的地方纔能獲得價值。

代碼

#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;

struct node{
	int to;
	int next;
}edge[maxn<<1];
int v[maxn],w[maxn];
int head[maxn],cnt;
int n,m;
int dp[maxn][maxn];
int in[maxn];

void init(){
	cnt = 0;
	memset(in,0,sizeof(in));
	memset(dp,0,sizeof(dp));
	memset(head,-1,sizeof(head));
}

void add(int u,int v){
	in[u]++;
	in[v]++;
	edge[cnt].to = v;
	edge[cnt].next = head[u];
	head[u] = cnt++;
}

void dfs(int cur,int pre){
	for(int k = w[cur];k<=m;k++){
		dp[cur][k] = v[cur];
	}
	for(int i = head[cur];i!=-1;i = edge[i].next){
		if(edge[i].to != pre){
			int to = edge[i].to;
			dfs(to,cur);
			for(int most = m;most>=w[cur];most--){
				for(int k = 1;k<=most-w[cur];k++){
					dp[cur][most] = max(dp[cur][most],dp[cur][most-k]+dp[to][k]);
				}
			}
		}
	}
}

int main(){
	while(~scanf("%d%d",&n,&m) && ~n && ~m){
		init();
		for(int i = 1;i<=n;i++){
			scanf("%d%d",&w[i],&v[i]);
			w[i] = (w[i]+19)/20;
		}
		for(int i = 1;i<n;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			add(u,v);
			add(v,u);
		}
		for(int i = 1;i<=n;i++){
			if(in[i] == 2 && w[i] == 0 && i!=1){
//				printf("Mark %d to 1\n",i);
				w[i] = 1;
			}
		}
		if(m<=0){
			printf("0\n");
		}else{
			dfs(1,0);
			printf("%d\n",dp[1][m]);
		}
//		for(int i = 1;i<=n;i++){
//			for(int j = 1;j<=m;j++){
//				printf("%3d",dp[i][j]);
//			}
//			putchar('\n');
//		}
	}
	
	return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章