HDU-2222 Keywords Search (AC自動機,模板題)

Keywords Search

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

題意

第一行:t。共有t組測試樣例。
每個測試點:
一個n,共有n個字符串。
給一個T串。
問在上面的n個字符串有幾個能與下面的串匹配。

我的理解

AC自動機板子題。
我是從B站上學的一個大佬的視頻,鏈接在此:UESTCACM 每週算法講堂 AC自動機

代碼

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1000010;
const int maxt = 500010;

struct  Aho_Corasick{
	struct Trie
	{
		int next[26];
		int fail,cnt;
	}trie[maxt];

	int size;
	queue<int> q;

	void init(){
		while(q.size())	q.pop();
		size = 1;
		for(int i = 0;i<maxt;i++){
			memset(trie[i].next,0,sizeof(trie[i].next));
			trie[i].fail = trie[i].cnt = 0;
		}
	}

	void insert(char *s){
		int len = strlen(s);
		int now = 0;
		for(int i = 0;i<len;i++){
			int id = s[i]-'a';
			if(trie[now].next[id]){
				now = trie[now].next[id];
			}else{
				trie[now].next[id] = size++;
				now = trie[now].next[id];
			}
		}
		trie[now].cnt++;
	}

	void build(){
		trie[0].fail = -1;
		q.push(0);
		while(q.size()){
			int u = q.front();
			q.pop();
			for(int i = 0;i<26;i++){
				if(trie[u].next[i]){
					if(u==0)	trie[trie[u].next[i]].fail = 0;
					else{
						int v = trie[u].fail;
						while(v!=-1){
							if(trie[v].next[i]){
								trie[trie[u].next[i]].fail = trie[v].next[i];
								break;
							}
							v = trie[v].fail;
						}
						if(v == -1){
							trie[trie[u].next[i]].fail = 0;
						}
					}
					q.push(trie[u].next[i]);
				}
			}
		}
	}

	int Get(int u){
		int res = 0;
		while(u){
			res += trie[u].cnt;
			trie[u].cnt = 0;
			u = trie[u].fail;
		}
		return res;
	}

	int match(char *s){
		int res = 0,now = 0;
		int len = strlen(s);
		for(int i = 0;i<len;i++){
			int id = s[i]-'a';
			if(trie[now].next[id]){
				now = trie[now].next[id];
			}else{
				int p = now;
				while(p!=-1 && trie[p].next[id] == 0){
					p = trie[p].fail;
				}
				if(p == -1){
					now = 0;
				}else{
					now = trie[p].next[id];
				}
			}
			if(trie[now].cnt){
				res += Get(now);
			}
		}
		return res;
	}
}aho;

int n;
char s[maxn];

int main(){
	int t;cin>>t;
	while(t--){
		scanf("%d",&n);
		aho.init();
		for(int i = 0;i<n;i++){
			scanf("%s",s);
			aho.insert(s);
		}
		aho.build();
		scanf("%s",s);
		printf("%d\n",aho.match(s));
	}

	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章