UVA1200 LA2972 POJ2295 ZOJ2492 A DP Problem【輸入】

In this problem, you are to solve a very easy linear equation with only one variable x with no parentheses! An example of such equations is like the following:
2x − 4 + 5x + 300 = 98x
    An expression in its general form, will contain a ‘=’ character with two expressions on its sides. Each expression is made up of one or more terms combined by ‘+’ or ‘-’ operators. No unary plus or minus operators are allowed in the expressions. Each term is either a single integer, or an integer followed by the lower-case character x or the single character x which is equivalent to 1x.
    You are to write a program to find the value of x that satisfies the equation. Note that it is possible for the equation to have no solution or have infinitely many. Your program must detect these cases too.
Input
The first number in the input line, t (1 ≤ t ≤ 10) is the number of test cases, followed by t lines of length at most 255 each containing an equation. There is no blank character in the equations and the variable is always represented by the lower-case character ‘x’. The coefficients are integers in the range (0…1000) inclusive.
Output
The output contains one line per test case containing the solution of the equation. If s is the solution to the equation, the output line should contain ⌊s⌋ (the “floor” of s, i.e., the largest integer number less than or equal to s). The output should be ‘IMPOSSIBLE’ or ‘IDENTITY’ if the equation has no solution or has infinite solutions, respectively. Note that the output is case-sensitive.
Sample Input
2
2x-4+5x+300=98x
x+2=2+x
Sample Output
3
IDENTITY

Regionals 2003 >> Asia - Tehran

問題鏈接UVA1200 LA2972 POJ2295 ZOJ2492 A DP Problem
問題簡述:(略)
問題分析
    解方程問題,實際上是輸入流處理問題。
    假設方程爲a+bx=c+dx,那麼方程變爲(a-c)+(b-d)x=0,解爲x=(a-c)/(b-d)。程序中,需要先算出a、b、c和d,然後再算出a-c和b-d。需要考慮b-d爲0的情況。
程序說明:(略)
參考鏈接:(略)
題記:(略)

AC的C++語言程序如下:

/* UVA1200 LA2972 POJ2295 ZOJ2492 A DP Problem */

#include <iostream>
#include <cmath>

using namespace std;

int main()
{
    int t;
    string s;

    cin >> t;
    while(t--) {
        cin >> s;

        int num = 1, sign = 1;
        int a = 0, b = 0;
        int flag = 0;       // 方程左右標識,0指左邊,1指右邊

        for(int i = 0; s[i]; i++) {
            if(s[i] == '=') {
                sign = 1, num = 1;
                flag = 1;
            } else if(s[i] == '+') {
                sign = 1, num = 1;
            } else if(s[i] == '-') {
                sign = -1, num = 1;
            } else {
                num = (s[i] == 'x') ? 1 : 0;
                while(isdigit(s[i])) {
                    num = num * 10 + s[i] - '0';
                    i++;
                }
                if(s[i] == 'x') {
                    if(flag == 0) b += num * sign;
                    else b -= num * sign;
                } else {
                    i--;
                    if(flag == 0) a -= num * sign;
                    else a += num * sign;
                }
            }
        }

        if(b == 0) {
            if(a == 0)
                cout << "IDENTITY" << endl;
            else
                cout << "IMPOSSIBLE" << endl;
        } else {
            int x = (int)floor((double)a / b);
            cout << x << endl;
        }
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章