1136 A Delayed Palindrome (20 分) 字符串相加

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

題意:字符串+字符串反轉=新字符串

問能否10次內,新字符串爲迴文。

#include<stdio.h>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int i,j,k;
	string a,b,c;
	cin>>a;
	b=a;
	reverse(a.begin(),a.end());
	for(i=0;i<10;i++)
	{
		if(a==b)
		{
			cout<<a<<" is a palindromic number.\n";
			break;
		}
		c=""; 
		k=0;
		for(j=a.size()-1;j>=0;j--)
		{
			c+=((a[j]-'0')+(b[j]-'0')+k)%10+'0'; 
			k=((a[j]-'0')+(b[j]-'0')+k)/10;
		}
		if(k) c+='1';//進位
		reverse(c.begin(),c.end());
		
		cout<<b<<" + "<<a<<" = "<<c<<endl;
		a=c;
		b=a; 
		reverse(a.begin(),a.end());
	}	
	if(a!=b)
	cout<<"Not found in 10 iterations.\n";
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章