[PAT]1101 Quick Sort (25 分)(樣例2段錯誤原因)

一、題意

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

 二、題解

題目大意是給出一段正數序列,判斷哪幾個數可能是在快速排序中當做中間值的數。即找出所有X,X滿足,所有在X前的數都小於X,所有在X後面的數都大於X。

樣例2段錯誤原因:有可能找不到這樣的數,那麼ans數組size就爲0,那麼就不能使用sort(ans.begin(), ans.end());進行排序了,所以需要判斷ans數組的大小是否爲0。

AC代碼:

#include <bits/stdc++.h>
using namespace std;

vector<int > nums;
vector<bool > maxflag;
vector<bool > minflag;

int main() {
    int n;
    cin>>n;
    maxflag.resize(n+5);
    minflag.resize(n+5);

    for(int i=0; i<n; i++) {
        int temp;
        cin>>temp;
        nums.push_back(temp);
    }

    fill(maxflag.begin(), maxflag.end(), false);
    fill(minflag.begin(), minflag.end(), false);
    int maxnum;
    int minnum;
    maxnum = nums[0];
    minnum = nums[n-1];

    //判斷nums[i]是否大於所有前面的數
    for(int i=0; i<n; i++) {
        if(nums[i] >= maxnum) {
            maxflag[i] = true;
            maxnum = nums[i];
        } else {
            ;
        }
    }
    //判斷nums[i]是否小於所有後面的數
    for(int i=n-1; i>=0; i--) {
        if(nums[i] <= minnum) {
            minflag[i] = true;
            minnum = nums[i];
        } else {
            ;
        }
    }
    vector<int > ans;
    for(int i=0; i<n; i++){
        if(maxflag[i] && minflag[i]){
            ans.push_back(nums[i]);
        }
    }
    cout<<ans.size()<<endl;
    int m = ans.size();
    if(ans.size() == 0){
        cout<<endl;
        return 0;
    }

    sort(ans.begin(), ans.end());

    for(int i=0; i<ans.size()-1; i++){
        cout<<ans[i]<<" ";
    }
  
    cout<<ans[m-1]<<endl;
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章